Проблемы с pymongo 3.0

Последняя версия pymongo (3.0) содержит баг

raise ConnectionError("Cannot connect to database %s :\n%s" % (alias, e))
mongoengine.connection.ConnectionError: Cannot connect to database default :
False is not a read preference.

Баг висит уже минимум неделю в качестве решения пока предлагают сделать даунгрейд. У меня нормально работает версия 2.8:

pip install pymongo==2.8

 

Добавлено: 2015-04-14


Поделиться:

Оставить комментарий

Комментарий появится после одобрения.

Поля со значком * обязательны для заполнения.